Skip to main content

Project Templates

An introduction to the Project Templates functionality in SI

A
Written by Ashok P

A "Project Template" is a template that holds many details of a project that you can reuse for new projects. With project templates, you can create new projects from a template, with most details coming into the project automatically. These details can be modified to suit the project's requirements.

In SI, you can use the Project Templates functionality as follows:

  • Create a template from a project and, if needed, edit the template in the Project Template Editor interface.

  • Create a project from a saved template, change or remove details that came with the template, and add new details to the project.

Project templates have the following additional capabilities:

  • Project templates can be edited like a project. You can add new items, remove items, add cover and scope of work files, compare and sync costs, assign price type, add checklists, create a Gantt chart, and more.

Create Template

New SI deployments do not come with any templates. To create templates, you need to first create projects and then create templates from those projects.

To create a template:

1/ Go to Project Explorer, click the project, and click Create > Template in the Project tab in the ribbon.

2/ In the Create Project Template modal, add a name and description for the template and select the files in the project that you want in the template.

3/ Once done, click Save.

If you have a Gantt chart in the project, you will be prompted to choose if you want that to be part of the template.

This way, you can create a collection or project templates.

View Templates

If you want to view all your templates, go to Project Explorer and click View > Templates in the Project tab in the ribbon.

You can use almost all the features seen in the ribbon, except for Approval, Job Costing, and other functions that don't apply to templates.

Edit Template

If you double-click a template in Project Explorer when viewing Templates, you will see the Project Template Editor interface. This interface is similar to the Project Editor interface. You have the option to customize the template by using the features seen in the ribbon.

Check out this collection of articles.

Create Project from Template

When you want to create a project from a template, go to Project Explorer, click Create > From Template in the Project tab in the ribbon, and complete the steps in the wizard.

Check out this article for more details.

Did this answer your question?